Go Back   Mitsubishi Lancer Register Forum > Technical > ECU / Mapping

Reply
 
Thread Tools Rate Thread Display Modes
Old 22-06-2017, 09:55   #1
eTiLiKo
Registered User
 
Join Date: Dec 2008
Posts: 87
EVO 6 TME reflashing problem

Mitsubishi Lancer EVO 6 TME, tactrix 2.0 cable, windows 10. ECUFLASH version 1.444799
I'm able to read the ecu, but the writing gives me this error :

An error occurred while reflashing. See the log for details.

You were in the process of reflashing your ECU and
some memory areas have already been erased / written -
Start the reflashing process again, and the software
should be able to resume where it left off. If you are
still having trouble, save the log file, and send it to
http://openecu.org or [email protected] and see if
someone can help you.


This is the log :

[16:26:55.818] opening rom file C:/Users/Matteo/Desktop/Mitsubiishi/mod2 solenoide 3 vie.bin

[16:26:55.828] 25580000 (110 tables) inheriting evo5base (86 tables)

[16:26:55.833] 131072 byte image read.

[16:26:55.834] using metadata XML ID 25580000 from file D:/OpenECU/EcuFlash/rommetadata/mitsubishi/evo/25580000 1999 JDM Lancer Evo 6 RSII MT.xml

which inherits XML ID evo5base from file D:/OpenECU/EcuFlash/rommetadata/mitsubishi/evo/evo5base.xml

[16:26:55.834] ---notes for evo5base---

2012/11/19 [Tactrix] updated to include missing elements.

---notes for 25580000---

2012/11/19 [Tactrix] Updated to standardized file naming.

2012/11/21 [Tactrix] Removed - from "Idle Stepper Look-up".

2012/11/21 [Tactrix] Visually examined tables for obvious errors, but no in-car verification has been done.

[16:27:06.247] using metadata XML ID read_evo65 from file D:/OpenECU/EcuFlash/rommetadata/read templates/read_evo65.xml

[16:27:08.237] J2534 API Version: 04.04

[16:27:08.237] J2534 DLL Version: 1.02.4798 Jun 13 2016 17:17:10

[16:27:08.237] Device Firmware Version: 1.16.4769

[16:27:08.237] Device Serial Number: TAoQ6jwd

[16:27:15.308] sending init sequence 2

[16:27:15.313] got 0x13 response instead of 0x11

[16:27:15.313] sending init sequence 3

[16:27:15.665] entering bootloader

[16:27:15.668] sending kernel size (2029)

[16:27:15.675] sending kernel load address (0x0000F000)

[16:27:15.686] uploading kernel

[16:27:16.029] verifying kernel checksum response

[16:27:16.033] kernel valid

[16:27:16.234] kernel get version

[16:27:16.246] kernel version is : OpenEcu Mitsubishi H8/539F Kernel V1.07

[16:27:16.246] reading kernel comm buffer size

[16:27:16.252] comm buffer size set to 256

[16:27:16.252] reading kernel flash buffer size

[16:27:16.257] flash buffer size set to 1024

[16:27:16.269] -- flashing image to ECU memory --

[16:27:16.670] -- comparing ECU flash memory pages to image file --

[16:27:16.670] seg start len ecu CRC32 img CRC32 same?

[16:27:16.819] LB7 00010000 00003000 D66508BD 497581B1 NO

[16:27:16.832] SB0 00013000 00000200 BD7BC39F BD7BC39F YES

[16:27:16.845] SB1 00013200 00000200 BD7BC39F BD7BC39F YES

[16:27:16.858] SB2 00013400 00000200 BD7BC39F BD7BC39F YES

[16:27:16.871] SB3 00013600 00000200 BD7BC39F BD7BC39F YES

[16:27:16.884] SB4 00013800 00000200 BD7BC39F BD7BC39F YES

[16:27:16.897] SB5 00013A00 00000200 BD7BC39F BD7BC39F YES

[16:27:16.910] SB6 00013C00 00000200 BD7BC39F BD7BC39F YES

[16:27:16.923] SB7 00013E00 00000200 BD7BC39F BD7BC39F YES

[16:27:17.118] LB6 00014000 00004000 1319EF62 1319EF62 YES

[16:27:17.313] LB5 00018000 00004000 DD6A28AA DD6A28AA YES

[16:27:17.510] LB4 0001C000 00004000 690B37D3 690B37D3 YES

[16:27:17.706] LB3 00020000 00004000 4B59475E 4B59475E YES

[16:27:17.901] LB2 00024000 00004000 5A67CA6B 5A67CA6B YES

[16:27:18.098] LB1 00028000 00004000 6C682304 6C682304 YES

[16:27:18.294] LB0 0002C000 00004000 C2E46898 C2E46898 YES

[16:27:18.294] kernel flash enable

[16:27:18.298] kernel blank flash page: addr: 00010000

[16:27:33.390] WARNING: failed to erase page at 00010000!

[16:27:33.390] kernel flash disable

[16:27:35.394] interface close



Sent an email to tactrix but none still replied, someone experienced the same error?
eTiLiKo is offline   Reply With Quote
Old 22-06-2017, 10:30   #2
Lee5
Moderator
 
Lee5's Avatar
 
Join Date: Apr 2003
Location: Kent
Car: Range Rover Sport~Porsche 911
My Car
Posts: 23,020
You are trying to flash back with the wrong file.
Read out using the TME drop down, if you have tried that try the other 5-6 drop down.

If nothing works you have bricked the ecu

Sent from my SM-G920F using Tapatalk
__________________


1st 500BHP E5 in the UK Running on Speed Density on Stock H8 Ecu

MLR Sprint Scrutineer

E5/6 Ecu SD Mapping Info Here & HERE
Lee5 is offline   Reply With Quote
Old 23-06-2017, 07:20   #3
eTiLiKo
Registered User
 
Join Date: Dec 2008
Posts: 87
I'm trying to flash a modified file of the original, read as TME.
The strange thing is that the very first try writing a file worked. Ecuflash gave me some error but resumed and completed the write.

I'll try reading it as evo 5-6 as per your suggestion.
eTiLiKo is offline   Reply With Quote
Old 17-07-2017, 13:23   #4
eTiLiKo
Registered User
 
Join Date: Dec 2008
Posts: 87
Read ad evo 5/6, file modded than tried to relfash, still no success.
The car runs fine, I really don't think that the ecu is bricked, how is it possible?
ideas?
eTiLiKo is offline   Reply With Quote
Old 17-07-2017, 21:24   #5
evonut270
Senior User
 
Join Date: Dec 2003
Location: Scotland
Car: evo 2 with an 8 ecu
My Car
Posts: 7,617
Did you chose the correct dropdown in ecuflash
evonut270 is offline   Reply With Quote
Old 17-07-2017, 22:01   #6
Senior User
 
Andy@FCM's Avatar
 
Join Date: Nov 2010
Posts: 315
Open the xml file that's its using in a text editor and add an A to the ecu chip code and the open ecuflash
Andy@FCM is offline   Reply With Quote
Old 24-07-2017, 11:16   #7
eTiLiKo
Registered User
 
Join Date: Dec 2008
Posts: 87
Quote:
Originally Posted by [email protected] View Post
Open the xml file that's its using in a text editor and add an A to the ecu chip code and the open ecuflash
What do you mean?
This is the XML header :

<rom>
<romid>
<xmlid>25580000</xmlid>
<internalidaddress>1021a</internalidaddress>
<internalidhex>25580000</internalidhex>
<caseid>MR420994</caseid>
<ecuid>Evo6 RSII</ecuid>
<make>Mitsubishi</make>
<market>JDM</market>
<model>Evo</model>
<submodel>6 RSII</submodel>
<transmission>Manual</transmission>
<year>1999</year>
<flashmethod>mitsukernel</flashmethod>
<memmodel>H8539F</memmodel>
</romid>

<notes>
2012/11/19 [Tactrix] Updated to standardized file naming.
2012/11/21 [Tactrix] Removed - from "Idle Stepper Look-up".
2012/11/21 [Tactrix] Visually examined tables for obvious errors, but no in-car verification has been done.
</notes>

<include>evo5base</include>
eTiLiKo is offline   Reply With Quote
Old 24-07-2017, 12:20   #8
Senior User
 
Andy@FCM's Avatar
 
Join Date: Nov 2010
Posts: 315
Take this line <memmodel>H8539F</memmodel> and change to <memmodel>H8539FA</memmodel>

Andy
Andy@FCM is offline   Reply With Quote
Old 24-07-2017, 20:28   #9
eTiLiKo
Registered User
 
Join Date: Dec 2008
Posts: 87
Quote:
Originally Posted by [email protected] View Post
Take this line <memmodel>H8539F</memmodel> and change to <memmodel>H8539FA</memmodel>

Andy
Thanks mate, I'll try and report
eTiLiKo is offline   Reply With Quote
Old Yesterday, 06:36   #10
eTiLiKo
Registered User
 
Join Date: Dec 2008
Posts: 87
Nothing changed, still

WARNING: failed to erase page at 00010000!

eTiLiKo is offline   Reply With Quote
Mitsubishi Lancer Register
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT. The time now is 18:40.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.